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You can develop C and C++ apps for BlackBerry 10 using the BlackBerry Native Plug-in for Microsoft Visual Studio in your
Microsoft Visual Studio development environment.

Key features of the Visual Studio plug-in
The BlackBerry Native Plug-in for Microsoft Visual Studio adds the following features to your Microsoft Visual Studio
installation.

BlackBerry Solution Configuration
You can create a new solution configuration that is specific to the BlackBerry 10 OS. With this solution configuration, you
can adjust the settings for your project to associate it with the correct libraries and resources that you need to compile
against the Native SDK. When you use this configuration, Microsoft Visual Studio uses the Native SDK compiler to build
your app.

BlackBerry build and deployment scenarios
You can use the Build Solution menu and the Run button for both Debug and Release work on BlackBerry projects.

Code signing keys
You can manage the code signing keys that you obtained from the BlackBerry Signing website. You can register,
unregister, back up, and restore your signing keys.

Application properties
You can edit application properties using the bar-descriptor.xml file, which is added when a new BlackBerry Solution
Target is created. This file is required to create a BlackBerry 10 application.

Importing apps
You can import apps that you have developed and exported as Win32, or you can import apps that you have developed in
the Native SDK.
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Debugging
You can use the integrated debugging functions of Microsoft Visual Studio to perform basic debugging techniques. You can
count breakpoint hits, step through code using step into/over/out, debug threads and processes, evaluate expressions,
view call stacks, break at functions, and hit breakpoints.

Get started

Create or import a project

Download and configure the tools you need to start creating Get started creating a new app or import an existing app.
apps using the BlackBerry 10 OS and Microsoft Visual
Create or import a project
Studio.
Get Started

Get started
Before you can start developing for BlackBerry 10 OS, there Note:
are a few things that you need to do.
To develop using the BlackBerry Native Plug-in for
Microsoft Visual Studio, you must be using Microsoft Visual
Studio 2010 on Windows 7 or Windows 8.
The plug-in is not supported on Microsoft Visual Studio
Express editions.

On this page
•

Request a vendor account

•

Get code signing and debug token keys

•

Set up your device

•

Install the BlackBerry 10 Device Simulator

•

Download and install the QNX Momentics IDE and SDK

•

Set up the QNX Momentics IDE

•

Install the BlackBerry Native Plug-in for Microsoft Visual
Studio

•

Start Microsoft Visual Studio

Request a vendor account
You need to request a vendor account on the vendor portal. For more information about accounts, see Managing vendor
portal accounts in the BlackBerry World documentation.
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Get code signing and debug token keys
You need code signing keys to distribute your application. You also need debug tokens to test your application on a device.
You don't need code signing keys or debug tokens when using the BlackBerry 10 Device Simulator. To request your signing
and debug token keys, fill in and submit a BlackBerry Keys Order Form. Make sure you remember your registration PIN.
You will need this PIN later in the signing registration process.
After you submit your request, you receive two CSJ registration files by email:
•

A RIM Development Key (RDK), which you use to sign your applications

•

A debug token (PBDT) file, which you use to generate debug tokens

Save these registration files on your computer. You will need them when you configure your environment for application
development.
If you have already used code signing keys to register another BlackBerry 10 device on your computer, you don't need to
register a new set of code signing keys. If you need help getting code signing keys, visit Code Signing Support.

Set up your device
To upload and test apps on a device, you must enable Development Mode on your device. This mode allows you to
remotely install and launch an app. If you don't intend to do development activities, disable Development Mode for
increased security. Development mode expires automatically in 10 days. If you reboot a device, Development Mode is
disabled automatically.
By default, Development Mode is set to On or enabled for the simulator.
To enable Development Mode on your device:
1. On the home screen, swipe down from the top of the screen or find the Settings app on your home screen.
2. Navigate to Settings > Security and Privacy > Development Mode.
3. Set the Development Mode toggle switch to On.
4. If you are prompted, enter the password for your device, and tap OK.
You can connect a device to the IDE using Wi-Fi or with a USB cable. Navigate to Settings > Storage and Access and make
sure that the USB Connection option is set to Autodetect or to the target platform.

Install the BlackBerry 10 Device Simulator
If you don't have a BlackBerry 10 device, you can use the BlackBerry 10 Device Simulator to test your app.
For more information about the simulator, see Installing the simulator.
1. Download the BlackBerry 10 Simulator.
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2. Follow the instructions to install and configure the simulator.

Download and install the QNX Momentics IDE and SDK
To get the code libraries and command line tools, you need to install the QNX Momentics IDE for Windows.
Download the QNX Momentics IDE
When you start the IDE, you can download and install the BlackBerry 10 Native SDK from within the IDE. The IDE provides
a wizard that helps you select an SDK that matches the connected device.
If this is your first time installing the IDE, you are prompted with a wizard that helps you select an SDK that matches your
device.
If you already have a version of the IDE installed or you’re using an old workspace, you need to update your SDK after you
start the BlackBerry 10 Native SDK. To get a new version of the SDK, click Help > Update API Levels. You can select a
Gold version of the SDK or a beta version of the SDK using the tabs.
For more information about API levels, see API levels in Using the QNX Momentics IDE.

Set up the QNX Momentics IDE
Now you can set up the QNX Momentics IDE for BlackBerry.
1. Start the QNX Momentics IDE by using the BlackBerry 10 Native SDK shortcut created by the installer.
2. If you are prompted, choose a workspace or create a new workspace, and click OK. A workspace is a folder where you
keep your projects.
3. The IDE automatically tries to find a device that is connected to your computer. If your device is connected to your
computer, you can pair your device and then download the matching BlackBerry 10 Native SDK. Follow the steps in the
wizard to download and install an SDK version for your development environment.
Note: If you already have a version of the IDE installed or you’re using an old workspace, you need to update your SDK
after you start the BlackBerry 10 Native SDK. To get the new version of the SDK, click Help > Update API Levels. You
can select a Gold version of the SDK or a beta version of the SDK using the tabs.
Tip: You can also launch the BlackBerry Deployment Setup Wizard manually anytime:
1. In Windows and Linux, click Window > Preferences. In Mac OS, click Momentics > Preferences.
2. Click BlackBerry.
3. Click BlackBerry Deployment Setup Wizard.
Now you are ready to download and install the BlackBerry Native Plug-in for Microsoft Visual Studio!
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Install the BlackBerry Native Plug-in for Microsoft
Visual Studio
Make sure you have already installed Microsoft Visual Studio 2010 before you install the plug-in.
1. Download the BlackBerry Native Plug-in for Microsoft Visual Studio.
2. Launch the plug-in installation file.
3. Follow the steps in the wizard.
4. Click Finish.
If you want to remove the plug-in you can uninstall it using the Windows Control Panel.

Start Microsoft Visual Studio
When you have installed the QNX Momentics IDE, the Native SDK, and the plug-in, you're ready to get started on your app.

Configure your development environment
When you open Microsoft Visual Studio, the BlackBerry tab
is displayed. The BlackBerry tab is where you configure
your development environment.
The first thing you need to do is register your code signing
keys. Then, you need to set a device target and install a
debug token.

Note:

On this page
•

Register your code signing keys

•

Set a device target

•

Install a debug token

Register your code signing keys
To register your code signing keys:
1. When you receive your two CSJ files, save the registration files on your computer.
2. In Microsoft Visual Studio, on the BlackBerry menu, click Signing.
3. In the BlackBerry Signing Authority section, click Register.
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4. In the Registration window, complete the RDK CSJ Path field and the PBDT CSJ Path field by browsing to the location
where you saved the CSJ files.
5. In the CSJ Pin field, enter the PIN that you used to fill out the code signing keys request form.
6. In the CSK Password field, enter a password. This is the keystore password that you use to create a developer
certificate.
7. Confirm the password and click OK.
To manage your code signing keys, in Microsoft Visual Studio, click BlackBerry > Signing.

In the Code Signing Properties window, you can register, unregister, backup, and restore your signing keys.
•

Register: To register your signing keys click Register. You must register before you can sign your app.

•

Unregister: To remove your keys, click Unregister. You need to request new keys before you can sign your app.

•

Back up: To create a backup of your signing keys or if you want to move your keys from one computer to another, click
Backup. If you don't have a backup and you lose your signing keys or forget your password, you need to re-register with
BlackBerry. After re-registering, a new version of your app will appear as a new app and won't have access to shared
data from previous versions.

•

Restore: If you moved your keys from one computer to another, click Restore to restore your keys.

Set a device target
When you set a device target, you need to choose which version of the BlackBerry 10 Native SDK you are going to use and
then set either a BlackBerry Device Target or a BlackBerry Simulator Target. This target is used when you build your
solution. You can connect a device to Microsoft Visual Studio using Wi-Fi or with a USB cable.
1. In Microsoft Visual Studio, on the BlackBerry menu, click Settings.
2. In the BlackBerry NDK Settings section, in the NDK Path drop-down list, choose the version of the BlackBerry 10
Native SDK you want to use to develop your app.
3. If you are using a physical device, under BlackBerry Device Target, in the IP Address field, enter the IP address for the
BlackBerry device attached to your computer.
4. If you are using a simulator, under BlackBerry Simulator Target, in the IP Address field, enter the IP address for the
simulator.
5. Enter the password for your BlackBerry device or simulator.
6. Click OK.
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Install a debug token
A debug token allows you to deploy unsigned apps on a device. You don't need a debug token if you are using a simulator.
Before you complete these steps, make sure that you request a vendor account and set up the QNX Momentics IDE. Also,
make sure that you have set a device target.
Note: You can only register one device at a time.
To install a debug token:
1. In Microsoft Visual Studio, on the BlackBerry menu, click Debug Tokens.
2. If you haven't set up your signing keys you will be asked to enter your password. In the Reset CSK Password dialog box,
enter your CSK Password, and click OK.
3. In the Password successfully reset dialog box, click OK.
4. In the Debug Tokens dialog box, click Add.
5. Click Close.

Debug tokens are valid for 30 days and when the token expires, the device no longer allows unsigned apps that rely on that
token to run. You can generate a new token using the same CSJ keys. To generate a new token, in Microsoft Visual Studio,
on the BlackBerry menu, click Debug Tokens and click Renew.

Create or import a project
You can open an existing project in Microsoft Visual Studio
or create a new one and populate it with your resources. If
you already created a project using the QNX Momentics
IDE, you can import your project.

Note:

On this page
•
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•

Create a new project

•

Import a Native SDK project

Convert a Win32 project
You have already developed a Win32 app. Now you want to port it to BlackBerry 10 OS. If you create a new project using
the Win32 template, a new BlackBerry solution target is created using the Win32 build target configuration as its template.
Every app is a little different, so here are the general guidelines you need to follow to add a bar-descriptor.xml file into your
project:
1. In Microsoft Visual Studio, go to File > Open > Project/Solution and open your Win32 project.
2. Create a BlackBerry solution target.
3. Click Close.
Every porting project is a little different but you might encounter some build issues that you need to resolve. Getting started
with porting can help you get your existing app running quickly.

Create a new project
You can create a new project from scratch. When you use the <Empty> template, a new BlackBerry solution target is
created using the default settings defined by Microsoft Visual Studio. When you use this configuration to build or run your
app, Microsoft Visual Studio builds using the BlackBerry Native SDK compilers rather than the default Win32 compilers.
1. In Microsoft Visual Studio, go to File > New > Project.
2. Click <Empty>.
3. Enter a name for your project and click OK.
When you set your targets, you can start developing your app.

Import a Native SDK project
If you have a BlackBerry 10 OS project that was created using the QNX Momentics IDE, you can import your existing Native
SDK project into Microsoft Visual Studio. Currently, only C and C++ are supported.
1. In Microsoft Visual Studio go to the File menu and click New > Project.
2. In the New Project dialog box, click Empty Project.
3. In the Name field, enter a Name for the project.
4. In the Location field, choose a location for the project.
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5. If you already have a solution open, in the Solution drop-down list, click Create new solution or Add to solution. If this
is a new project, the Solution drop-down list is not available.
6. Click OK.
7. In the Solution Explorer, right click the project name.
8. Click Import BlackBerry Core Native Project.
9. In the browser, navigate to your QNX Momentics IDE project and double-click the .cproject file.
10. In the Import Summary window, review the files that were imported. Note that all files are imported including your bardescriptor.xml and errors.
11. Click OK.
If you created a Managed project in the QNX Momentics IDE, the linker settings can be imported from the .cproject file. If
you created an Unmanaged project, the libraries you need to add in the linker are found in the common.mk file.

Configure your app
After you set up your development environment, you need
to configure your app so that you can build and test it. You
can add assets, permissions, and libraries to your app.

Note:

On this page
•

Create a BlackBerry solution target

•

Configure the bar-descriptor.xml file

•

Add permissions to your app

•

Add assets to your app

•

Add libraries to your app

Create a BlackBerry solution target
A BlackBerry solution target is the build target configuration for your app. The solution target is device specific, which
means that you must create a BlackBerry target first and then you can create another target, such as the simulator, and
base it on the BlackBerry target or on Win32.
To create a build target configuration for your BlackBerry app:
1. In Microsoft Visual Studio, on the Build menu, click Configuration Manager.
2. In the Configuration Manager window, in the Active solution platform drop-down list, click New.
3. In the New Solution Platform window, in the Type or select the new platform drop-down list, click BlackBerry.
4. In the Copy settings from drop-down list, click <Empty> or Win32.
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5. Click OK.
6. Click Close.

Configure the bar-descriptor.xml file
The bar-descriptor.xml file (BAR) is the application descriptor file that is added to your project when you create a new
BlackBerry Solution Target for your project. This application descriptor file is required when you create an app for the
BlackBerry 10 OS.
1. In Microsoft Visual Studio, in the Solution Explorer, double-click the bar-descriptor.xml file.
2. Click Set from Debug Token. If you have your debug token set up already, the data from your debug token is imported.

Note: You can modify some of the information on the bar-descriptor.xml page.

Add permissions to your app
From the Permissions drop-down list, you can choose which permissions you want to add to your app. For more
information about app permissions, see App permissions in Developing with the Native SDK.

Add assets to your app
From the Asset Configuration drop-down list, you can choose which Build Configuration to use and add assets to your app.

Add libraries to your app
If you have converted your project from a Win32 project to a BlackBerry project, you will need to find the equivalent
BlackBerry libraries for your project and add them to your project to build it.
1. In Microsoft Visual Studio, on the Project menu, click Properties.
2. Click Linker and add the required libraries.

13

API Reference
DRAFT - BlackBerry Internal Use

Using Microsoft Visual Studio

Build, test, and deploy your app
Before you build your BlackBerry app, check your project's
dependencies and verify the output paths in your project's
properties. Your output paths must match the paths
defined in the bar-descriptor.xml file.

Note:

On this page
•

Build your app

•

Test your app

•

Deploy your app on a target

Build your app
When you use the BlackBerry Native Plug-in for Microsoft Visual Studio, you can use a BlackBerry 10 device or a
BlackBerry 10 Simulator as the target device.
You can build a debug configuration which allows you to debug your app, or a release configuration which prepares your
app for signing. When you build your app, make sure you build it using the solution platform (BlackBerry or BlackBerry
Simulator) that corresponds to the target.

Build a debug configuration
When you build your app using the debug configuration, your code is compiled but not packaged into a BAR file.
To build a debug configuration:
1. On the Build menu, click Configuration Manager.
2. In the Configuration Manager window, in the Active solution platform drop-down list, click Debug.
3. In the Solution Explorer, right click the project.
4. Click Build.
5. From the Debug menu, click Start Debugging.
When you run your app using the debug configuration, your code is compiled, packaged into a BAR file, and deployed to
your chosen target device as configured in the BlackBerry > Settings menu.

Build a release configuration
When you build your app using the release configuration, your code is compiled and packaged into a BAR file. This option
does not deploy your app.
To build a Release configuration:
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1. On the Build menu, click Configuration Manager.
2. In the Configuration Manager window, in the Active solution platform drop-down list, click Release.
3. In the Solution Explorer, right click the project.
4. Click Build.

Test your app
Before you can test your app on a simulator or a device, you must set a device target.
•

If you are testing on a physical device, you must either sign your app or install a debug token on the device.

•

If you want to test an unsigned app on a device, you must create and install a debug token on the device and configure
the bar-descriptor.xml file.

You can use the integrated debugging functions of Microsoft Visual Studio to perform most of the basic debugging
techniques you need.
To test or debug your app:
1. In Microsoft Visual Studio, build a debug configuration. See Build your app.
2. Debug your program using the Microsoft Visual Studio debug tools. For more information, click Help > View Help.

Testing and debugging apps in the work space
If you develop enterprise apps, you can test your apps in the work space of your BlackBerry 10 device. In the development
environment you use, set your launch configuration to run or debug on a device, and switch to the work space before you
test the app.
There are a few considerations:
•

You must be running BlackBerry OS version 10.2 or later on your BlackBerry 10 device.

•

The administrator of the BlackBerry Device Service has to set the IT policy Development Mode Access to Work Space
rule to Allow to let you test apps in the work space.
Note: Only BlackBerry Enterprise Server 10.2 or later supports the Development Mode Access to Work Space IT policy.

•

The IT policy Development Mode Access to Work Space rule takes effect only if the Restrict Development Mode rule
is set to No.

•

If the Development Mode Access to Work Space rule is disabled, apps that you previously tested in the work space are
removed.

•

You can overwrite the apps that your administrator pushes, but if the Development Mode Access to Work Space rule is
disabled, your app is removed and isn’t reinstalled.

For more information about developing enterprise apps, see Developing Enterprise Applications.
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Deploy your app on a target
Before you can deploy your app on a target:
1. Set up your device (the simulator is already in Development Mode).
2. Build your app using one of the BlackBerry configurations.
3. Set the IP address and password for the BlackBerry device or simulator.
4. Connect a BlackBerry device to your computer or start the simulator.
To deploy your app:
1. In the Solution Explorer, right click the project.
2. Click Deploy.

Sign and publish
When you finish developing your app, you need to sign and
publish it. The BlackBerry World storefront is where users
discover, download, and review your app. Before you can
distribute your app in BlackBerry World, you must
cryptographically sign it using your code signing key. This
verifies the authorship of your app to users.

Note:

On this page
•

Sign your app

•

Increment the build number

•

Publish to BlackBerry World

Sign your app
When you build your app using Release mode, Development Mode is automatically set to Off.
To build your project:
1. In the Solution Explorer, right click the project.
2. Click Build.
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Increment the build number
You can sign an app only once per package build ID. If you have previously signed your app, you must increment the
package build ID of your app before you can sign your app again.
To increment the build number:
1. In the Solution Explorer, double-click the bar-descriptor.xml file of your app.
2. In the Package Information section, increase the value of the Package Build ID by one.
3. Rebuild your app.

Publish to BlackBerry World
You can distribute your app for BlackBerry 10 by submitting it to BlackBerry World.
For more information about publishing your app, visit BlackBerry World.

Use the Command line
Instead of using the Microsoft Visual Studio user interface, you can use command line tools to perform the following tasks:
•

To register your signing keys, see Configure app signing from the command-line.

•

To sign your application, see Sign your application from the command-line.

•

To create and deploy a debug token, and package and deploy your app, see Packaging and deploying apps.

•

To perform incremental updates, see Update your app from the command line.
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